0

Не заводится из приложения

Heyyo 12 months ago updated by Романыч48 10 months ago 11

С приложения часто не заводится авто(4 из 5 раз). Вылазит сообщение по типу "Ошибка. Не отвечает", и машина в приложении уходит в режим "не в сети"

с сайта в это же время - всё ок, заводится сразу, и в приложении появляется индикация работающего двигателя.

команды снятие и постановка на охрану из приложения работают без проблем.

симка теле2

Здравствуйте.

Команда из приложения передается на сервер, сервер передает команду в блок системы.

Команда с сайта передается на сервер, сервер передает команду в блок системы.

Поэтому автозапуск система выполняет в любом случае по команде с сервера. Для блока StarLine не важно, откуда пришла команда на сервер.

В Вашем случае рекомендую проверить: что происходит с автомобилем при получении команды на запуск из мобильного приложения? Автомобиль реагирует? Включается зажигание? Включается стартер?

если приложение выдаёт ошибку , то  авто не реагирует

если ошибки нет , то авто заводится без проблем

Спасибо за сообщение.

В таком случае рекомендую проверить работу приложения когда автомобиль стоит в другом месте.

проверено неоднократно , местонахождение авто или телефона не влияет.

Спасибо за сообщение. 

Приложение и сайт Вы используете на одном и том же устройстве? Или на разных, но с одним и тем же подключением к сети Интернет?

приложение только на одном устройстве(телефон), сайтом пользуюсь и с этого же устройства(этот же телефон) , и с другого ПК. 

ПК и тел на разных подключениях к интернету.

Возможно не обратили внимания - при неудачном АЗ с приложения статус встаёт "НЕ В СЕТИ". Может это как то прояснит ситуацию.

Т.е. захожу в приложение , статус "В СЕТИ" , нажимаю кнопку автозапуска .... идёт таймер , через ~30 сек выходит ошибка и приложение меняет статус на "НЕ В СЕТИ"

При этом в этот же момент с телефона Вы заходите на сайт и там устройство отображается в сети? в приложении не в сети, а на сайте в сети?

верно

завожу с сайта , тут же с приложения в виде push-уведомления приходит "двигатель запущен"

Здравствуйте. Если приложение отображает что система не в сети, а сайт в это время отображает что связь есть и выполняет команды, то рекомендую перепроверить работу приложения когда телефон подключен к другой сети для выхода в Интернет.