0

Общие библиотеки 2can2lin

roman05 7 месяцев назад обновлен Дмитрий Тонoян (Технический специалист StarLine) 6 месяцев назад 11

Приветствую. Где взять общую библиотеку для 2can2linv2? С can.starline не совместимость. 


Сегодня столкнулся с проблемой iKey на mazda 6 2010. После танцев с бубном обучилась, копикей прошёл, но не заводилась. Раньше помогала общая библиотека 5.0 именно на этой модели. Но для 2can2lin v2 нет общей библиотеки. Пришлось чип зашивать. 

Добрый день, коллега.

Но для 2can2lin v2 нет общей библиотеки. 

Ага. индивидуальные прошивки по отдельным машинам давно недоступны. Наверное - в целях сокращения объемов хранимой информации. Доступны только ОБЩИЕ прошивки по всем маркам-моделями по каждому из  адаптеров, по которым накоплены такие базы. По 2CAN+2LIN  и 2CAN+2LINv2

это тут

(если верить тому, что эти два типа модулей объединены одной строкой и значит программно должны быть совместимы - прошивки должны подходить)


Или именно прошивка 5.0.0.  отсюда не заработала в модуле версии 2 (2CAN+2LINv2)?

Конечно я имел ввиду общую прошивку по всем маркам. Модули Объеденены в один раздел, но не совместимы... 

Модули Объеденены в один раздел, но не совместимы...

5.0.0 для v2 свободно скачивается. 

Скачивается, но не прошивается. 

Здравствуйте.

Скачивается, но не прошивается.

Потому что в модулях есть аппаратная разница. В момент актуальности версии 5, этих модулей еще не было.

В последнее время  ехали в основном машины, которых нет в поддержке по CAN, А у меня еще лежат  в запасе А93 со  старыми 2CAN+2LIN, так что пока не могу ничего определенного сказать - нету у меня опыта скачивания и использования  прошивок под 2CAN+2LIN v2...

В момент актуальности версии 5, этих модулей еще не было.

Иными словами , Дмитрий, на модулях 2CAN+2LIN v2 прошивки  5.0 и ниже работать не будут?  Только версии 6.0 и выше? И что насчет версий ПО 5.3, 5.2, 5.1 в плане совместимости с 2CAN+2LIN v2? ТОже не будут работать? И нельзя-ли тогда разделить   в разделе https://can.starline.ru/ модули 2CAN+2LIN и 2CAN+2LINv2 на два подраздела по аналогии с v3  и  v4, раз такое дело?

+3

честно как то уже начинают надоедать - эти танцы с бубнами , индивид прошивка не работает = качай общую - вопрос зачем  индивид прошивка ? сделали  v4 , но кое что кое где не работает = зачем выпускать то что не работает  ? Alpha после одного  случая ставить не буду ( зря потерянное  время  ! ) ...

Мне представители сказали , когда Вы скачиваете с сайта прошивку она прежде сервером собирается и может что-то пойти не так и в итоге корявая прошивка.

+1

Что-то я слегка напрягся и ... пожалел, что не накачал  прошивок  всяких разных заранее, пока они точно были рабочими... Так всё-то не скачаешь  и на всю жизнь не запасешься...

Здравствуйте. Нам с Вами гораздо эффективнее будет рассматривать каждый конкретный случай отдельно, а не все в кучу.

Новые модули выпускаются для новых машин и новых функций, потому что аппаратной части старых модулей уже не хватает.

В абсолютном большинстве случаев достаточно просто скачать актуальную индивидуальную прошивку с сайта. 

Альфа - это тестовая версия. Она по сути выпущена под одну машину и очень мало тестировалась. Она может содержать ошибки.

Сервис поддержки клиентов работает на платформе UserEcho