+4

ПО can 5.2 загрузка через программатор

roman05 1 год назад обновлен eugenyc 1 год назад 33

Если заливать версию  5.2  через программатор, загрузка происходит успешно, но в настройки не попасть, ошибка чтения, напрямую в кан норм и заливается  и заходит в настройки. Пробовал на 4ех блоках. С 5.1 все нормально. У всех так? 

Пришлось пере заливать два раза тогда норм 5.2

Завтра попробую 2 раза залить 

Заливал 2 раза индивидуальную прошивку, оба раза прошивались успешно, оба раза заходил в настройки и оба раза не сохраняла настройки. Возможно и что то с модулем(или с контактами). Пробовал 2 программатора, одинаково. Другие версии не пробовал(слишком долго), настроил напрямую, заодно контакты подогнул.

я делаю как 

1. подключил программатор к блоку потом в ноут

2. обновляю ПО блока

3.сброс на заводские установки блок

4.обновляю can

5. сброс на заводские установки блок

6. отключаю программатор от ноута и от блока 

7. и подключаю блок и ноут

8. произвожу настройку

так всегда работает без сбоя  

P/S

ЕСЛИ В ПРОЦЕССЕ ОБНОВЛЕНИЯ БЛОКА БЫВАЕТ СБОЙ ЗАГРУЗКИ ТО ПЕРЕЗАГРУЖАЮ НОУТ

ЕСЛИ В ПРОЦЕССЕ  ОБНОВЛЕНИЯ CAN  БЫВАЕТ СБОЙ ЗАГРУЗКИ ТО ЗАЛИВАЮ ЗАНОВО 

STARLAIN МАСТЕР УДАЛИ И УСТАНОВИ ЗАНОВО 

На 6ти блоках проверил, одна и та же ошибка) и 2 ноута 

Если залить через программатор, затем подключиться напрямую в кан, то тоже не зайдет, пока не зальешь напрямую. Получается криво льётся прошивка, но при этом пишет что залита успешно. 

+2

Такая же ерунда

После перепрошивки модуля напрямую, потом в блоке сигнализации через программатор работает.

точно такие же ошибки последнюю неделю стали проявляться, в итоге кан модуль снимаем с платы прошиваем настраиваем , ставим в блок делаем настройку блока 

Вам уже ответил представитель Старлайн, что нужно сделать для правильной работы программатора и SLM?

+1

Тоже вопрос актуален, ждём какой нибудь информации от представителей. 

Такая же ерунда . вчера залил 5.2.0 индивид с сайта и началось - ошибка чтения и не совпадения . решил потерять время = залил 5.1 настроил и КАН НЕ ВИДЕТ МАШИНУ = психнул снял блок залил на прямую = всё ок !

Звонил официалам в голову - говорят криво скачивается прошивка с сайта. Качал 2 раза. Заливал.....баг повторялся.

Думал что только у меня такие проблемы. Похоже что с  5,2 что-то не так.

Евгений

+2

Здравствуйте. Давайте проверим вариант решения:

Вам нужно удалить файл базы данных (при незапущенном StarLine Мастере)

Файл расположен в скрытом каталоге AppData: C:\Users\_user_\AppData\Roaming\StarLine\StarLine-Master\_slmid_\firmwareDatabase.db

где, _User_ - это текущий пользователь, а _slmid_ - уникальный идентификатор приложения, выглядит как набор букв и цифр.

После этого запустите StarLine Мастер и проверьте работу системы.

Подтверждаю. После этой процедуры залил через программатор прошивку КАН, настроил, сохранил.

А у меня опять так же, даже после этой процедуры. Помогает заливка прошивки  2 раза подряд. 

удалил не помогло = возможно от винды зависит , у меня 7 .

У меня тоже 7. Единственно что, пробовал через программатор уже после того, как прошил модуль напрямую. Но, думаю, это не должно было повлиять, поскольку через программатор заново залил прошивку и настроил. В следующий раз, когда будет А93, проверю, будет видно...

попробовал дома ( тоже 7 ) если залить на прямую = через программатор работает нормально , или помогает двойная заливка через программатор ( ради интереса удалил всё что было в двух папках  =  AppData: C:\Users\_user_\AppData\Roaming\StarLine\StarLine-Master\ )

Не, я потом еще через программатор залил прошивку в модуль, уже установленный в блок.

На выходных попробую сразу через программатор.

Попробовал 2 блока сигнализаций А93 с магазина, на 2-х разных ноутах с 7 и XP. Такая же ерунда:

Подтверждаю, тоже проблемы заливки прошивок через программатор. Сегодня вообще не могу с сайта скачать прошивку! Может какие тех. работы?

дело в том, что скорость разная. если для подключения к процессору, то необходима 9600, если к кану через процессор, то нужна выше, точно не помню... 57600 чтоль, если подобрать скорость правильно, то подключается через программатор без проблем, НО!!! к процу потом не подключается... обратно нужно 9600 выставлять.

В двух словах, если поднять скорость. то подключается без проблем к кан, но, постоянно приходится менять скорость.... что вашпе как неудобно, особенно когда отладку делаешь.

ввобщем, сводит на нет, всю идею шить кан и настраивать через программатор....

видимо для программирования кана, его канал связи идет через процессор, а это замедляет работу связи.

адаптер-процессор-кан,

т.е если программа программатор сможет договорится с процессором на какой скорости они будут вести диалог, то к кан нужен быстрее поток, т.к. проц на две стороны связи разрывается.

пробуй поднять от 57600 до 115200, вот увидишь, кан будет отзываться и входить в настройки без проблем, проц не будет отзываться, хотя может и будет, но читаться точно не будет.

и винда и адаптер тут не причем.

тут нужно программатор доработать, чтоб при опросе устройств, когда ответит проц и кан модуль, программатор переключал частоту компорта выше при выборе раздела работы с кан модулем, не важно шить или настривать.

Так ведь до 5.2 нормально все было... 

а почему началось прошивки 5.2 = добавили новый пункт ( управление клаксоном ) что ли ?

Для справки...

Заметил что если подключать адаптер усб через кабель антенны, то с каном плохо вяжется, но если подключится усб адаптером через шлейф (отдельный шлейф от антенны) сразу в блок, то ошибок по установки связи, по прошивке, по настройке нет вообще.

Думаю это связано с тем, что остаток шлейфа сигнализации мы как правило сматываем перед блоком сигнализации. 

И если адаптер усб подключать к БС напрямую, то тоже все без проблем работает.

полагаю следующее... что перед установкой БС, лучше сразу разобрать БС и прошить кан модуль необходимой маркой, а уже потом собрать все, но с доступом к БС, для подключения адаптера, для финишной отладки.

Не очень все это дело работает через кабель уже установленной антенны.

Провел эксперимент, обрезал сверток кабеля от антенны на авто (спаял), все читается. шьется и настраивается без проблем).

В предыдущем своем посте (2 месяца назад) я пробовал прошивать вообще без кабеля трансивера, т.е. программатор напрямую в блок сигнализации. В общем, теперь сначала заливаю напрямую в модуль.

Сервис поддержки клиентов работает на платформе UserEcho