0

Как прошить кан модуль не разбирая блок

Niykov 3 months ago • updated 3 months ago 10

Здравствуйте, подскажите как прошить кан модуль не разбирая блок сигнализации, видел в описании изменения программы что такая возможность появилась, но при подключении к программатору, программа видит только саму сигнализацию, а кан модуль не видит.

С прошивки ЦБ Р1 появилась такая возможность. Если у Вас ниже ,то не получится.

Но следует учесть, что на данный момент прошивка P1 и выше существует только для блоков GK64 и выше. 

Кстати вопрос разработчикам, будет ли в будущем добавлена поддержка обновления CAN модуля через кабель трансивера для GK54 (GK34)?

Ведь GK54 было выпущено очень много сигнализаций. 

А есть какая нибудь таблица или закономерность по прошивкам, как узнать выше она или ниже Р1?

Версия прошивки пишется в StarLine Мастер после определения сигнализации. Но если же установщик или Вы не обновляли до этого прошивку (успешно), то версию можно посмотреть на коробке от сигнализации.

Где пишется версия прошивки и как посмотреть я знаю, вопрос был как определить выше Р1 или ниже Р 1 версия прошивки, вот например О1 выше или ниже?

+1

Ниже. Так как буква "О" в латинском алфавите идет перед "P". Сначала смотрится буква, потом цифра (если буквы одинаковые). Порядок следования версий можно посмотреть тут или тут (сверху самая новая версия).

Спасибо.

И еще вопрос, вчера прошивал блок, и во время прошивки программа закрылась с ошибкой, после этого сигнализация не на что не реагирует, это возможно исправить программно или же это менять процессор, и считается ли это гарантийным случаем?

Для начала попробуйте полностью обесточить центральный блок сигнализации минут на 5. Если это не поможет (скорее всего), то нужно будет обратитесь в сервис-центр для проведения диагностики.

+1

Кроме ПО блока, ПО кана тоже должно быть подходящее.


Требования к модулям CAN для настройки и обновления ПО через кабель трансивера:

  • поддерживаемые версии основных блоков: GK64, GK74, GK84, GR04, GR64;
  • минимальная версия ПО: P1;
  • поддерживаемые версии модулей CAN: 2CAN, CAN+LIN, 2CAN+LIN, 2CAN+LINv2
  • минимальная версия ПО CAN: 4.3.0
  • модуль CAN должен быть выпущен не ранее сентября 2015г

Как то такс..........